Error message after running "arc" command

Hi All,

I’m trying to do setup as per instructions

After running arc command , getting below error

Vikrams-MacBook-Air-2:SAMPLE vikram$ arc
appium.txt path: /Users/vikram/Documents/workspace/Android/SAMPLE/appium.txt
Exists? true
Loading /Users/vikram/Documents/workspace/Android/SAMPLE/appium.txt
Failed to match sequence (ALL_SPACE (TABLE / TABLE_ARRAY / KEY_VALUE / COMMENT_LINE){0, } ALL_SPACE) at line 3 char 1.
- Don't know what to do with "app = \"/Us" at line 3 char 1. Failed to match sequence (ALL_SPACE (TABLE / TABLE_ARRAY / KEY_VALUE / COMMENT_LINE){0, } ALL_SPACE) at line 3 char 1.- Don’t know what to do with "app = “/Us” at line 3 char 1.
/Users/vikram/.rvm/gems/ruby-2.1.1/gems/appium_lib-4.1.0/lib/appium_lib/driver.rb:290:in initialize': platformName must be set. Not found in options: {:caps=>{:newCommandTimeout=>999999}} (RuntimeError) from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/appium_console-1.0.1/lib/start.rb:16:innew’
from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/appium_console-1.0.1/lib/start.rb:16:in <top (required)>' from /Users/vikram/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:inrequire’
from /Users/vikram/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in require' from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/pry- in load_requires’
from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/pry- each' from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/pry-’
from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/pry- initial_session_setup' from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/pry-’
from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/pry- block in <top (required)>' from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/pry-’
from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/pry- block in parse_options' from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/pry-’
from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/pry- parse_options' from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/appium_console-1.0.1/lib/appium_console.rb:49:inmodule:Console
from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/appium_console-1.0.1/lib/appium_console.rb:31:in <module:Appium>' from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/appium_console-1.0.1/lib/appium_console.rb:30:in<top (required)>’
from /Users/vikram/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:73:in require' from /Users/vikram/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:73:inrequire’
from /Users/vikram/.rvm/gems/ruby-2.1.1/gems/appium_console-1.0.1/bin/arc:51:in <top (required)>' from /Users/vikram/.rvm/gems/ruby-2.1.1/bin/arc:23:inload’
from /Users/vikram/.rvm/gems/ruby-2.1.1/bin/arc:23:in <main>' from /Users/vikram/.rvm/gems/ruby-2.1.1/bin/ruby_executable_hooks:15:ineval’
from /Users/vikram/.rvm/gems/ruby-2.1.1/bin/ruby_executable_hooks:15:in `’
Vikrams-MacBook-Air-2:SAMPLE vikram$

Please let me know which step am I doing wrong here ?

I’ve placed appium.txt in same folder as apk file.

Thanks & Regards,

That error message means your appium.txt is invalid. What is the content of that file?

Hi Bootstraponline,

platformName = “android”
app = “/Users/vikram/Documents/workspace/Android/SAMPLE/api.apk”
deviceName = “Android”
avd = “training”

The issue was with double quotes from Mac TextEdit ( its double quotes are different / unique and not getting accepted ) , when I tried double quotes from TextMate , it worked fine.

Thanks again.



I have the same problem. This is the content of my appium.txt file

platformName = “ios”
platformVersion = “8.1”
deviceName =“iPhone Simulator”
app = “/Users/sara7213/Apps/ESRI/GitHub/appium/sample-code/apps/UICatalog/build/Debug-iphonesimulator/”

sauce_username = “”
sauce_access_key = “”

I tried textmate’s double quotes - it didnt help me either.

This is the error that I am getting when I run arc command in my console

skesavan:appium sara7213$ arc
WARNING: Nokogiri was built against LibXML version 2.9.0, but has dynamically loaded 2.7.8
appium.txt path: /Users/sara7213/Apps/ESRI/GitHub/appium/appium.txt
Exists? true
Loading /Users/sara7213/Apps/ESRI/GitHub/appium/appium.txt
/Users/sara7213/.rvm/gems/ruby-2.1.1/bin/ruby_executable_hooks:15: stack level too deep (SystemStackError)

Thanks in advance.

@pinkpreez I suggest not to try example given in sauce labs training material , as it has got some bugs which they didn’t fix even after I had requested many a times earlier.

Please refer to some open source project in github and try it out. I’m as well learning similar way.


No one is paid to maintain the training material so unfortunately they quickly become out of date. The stack level issue often happens when using an old appium_lib gem.

I recommend trying the latest version of appium + the ruby gems. The arc command can be used on the ruby_lib repository.

$ git clone
$ cd ruby_lib/ios_tests
$ arc

The developers are working on setting up a CI system so we can make sure the examples always pass. Also if you want Sauce to invest in better training, make sure to let them know.

@bootstraponline Please let me know if any help needed with maintaing test cases. I’ll be glad to contribute.

(thumbs up) for CI integration plans

Pull requests are welcome. I’m happy to code review any changes to the failing samples.


Good morning , sure I’ll plan for these tasks in coming days.


I am still seeing this issue. Tried Textmate edited doc as well. Is there a real solution?