Error on "app" capability on Visual Studio

I’m trying to use Appium on Visual Studio. I stablished the desired capabilities but when I try to run my test I receive an error from Appium on “app” capability.

I don’t know what am I doing wrong using this line:

cap.SetCapability(“app”, “/Users/Oscar_Aguiar/Downloads/app-debug.apk⁩”);.

*I’m using Appium on Visual Studio (both on their latest version)
*I’m using a real Android Device
*I tried to implement the same code from another developers and everything seems to be OK
*I tried using “appActivity” and “appPackage” capabilities with their respective path but none of them works (Appium always gives me an error on that line)
*The .apk file exists
*I’ve been using the same kind of .apk on Xamarin and they worked properly

public class Tests
    //Crearting instance for Appium driver
    private AndroidDriver<AndroidElement> driver;

    public void InitDriver()

        DesiredCapabilities cap;
        cap = new DesiredCapabilities();
        cap.SetCapability("platformName", "Android");
        cap.SetCapability("platformVersion", "7.0");
        cap.SetCapability("automationName", "UiAutomator2");
        cap.SetCapability("deviceName", "SM-J700M");
        cap.SetCapability("udid", "5203bcfc5346a361");
        cap.SetCapability("app", "/Users/Oscar_Aguiar/Downloads/app-debug.apk⁩");

        driver = new AndroidDriver<AndroidElement>(new Uri (""), cap);


    public void Test1()


    public void CloseDriver()


I expect the app launches on my device running the first steps of my Test

The output is the same error on Appium and Visual Studio on “app” capability

Appium server says: [MJSONWP] Encountered internal error running command: Error: The application at ‘/Users/Oscar_Aguiar/Downloads/app-debug.apk⁩’ does not exist or is not accessible

Visual Studio says: System.InvalidOperationException : An unknown server-side error occurred while processing the command. Original error: The application at ‘/Users/Oscar_Aguiar/Downloads/app-debug.apk⁩’ does not exist or is not accessible TearDown : System.NullReferenceException : Object reference not set to an instance of an object