Error: The instrumentation process cannot be initialized. Make sure the application under test is doesnot crash.Investigate logcat output

What does the above error mean? Started getting it all of a sudden and unable to launch appium session.

Any help greatly appreciated as this is blocking our project :frowning:

Sometimes it means there is a pop up on the screen that is blocking Appium. Hard to say without a log, which you could share as a git gist:

https://docs.github.com/en/get-started/writing-on-github/editing-and-sharing-content-with-gists/creating-gists

My github account has some authentication issue.Please find the logs in below link:

https://drive.google.com/file/d/10vvLxWOzEmF9XCD8MNyt5wDiIcSbMTi_/view?usp=sharing

appium.txt is server logs and instrumentation.txt is logcat logs

I researched on net and none of solutions worked.

Tried uninstalling uiautomator2 apks and it did not work.

Switching to uiautomator1 worked.But i do not want to go for it as it is not right approach as uiautomator1 is deprecated.

Please help.Thanks in advance for you time !

This is the error I’m seeing:

java.lang.IllegalStateException: UiAutomationService andr[email protected]59896baalready registered!

I found a document on killing the service that is already registered here:

https://debugah.com/app-automated-execution-error-uiautomationservice-android-accessibilityservice-iaccessibilityserviceclientstubproxy63c31ebalready-registered-20050/

One thing that seems peculiar about your setup is that there appear to be 5 devices connected to the computer:

[debug] [ADB] Connected devices: [{“udid”:“R3CM603JHVW”,“state”:“device”},{“udid”:“R3CN30YD8FP”,“state”:“device”},{“udid”:“R3CNB0FPA4N”,“state”:“device”},{“udid”:“R3CNC0EZPVH”,“state”:“device”},{“udid”:“R3CR315S5TV”,“state”:“device”}]

If you only connect one device does this problem go away? This seems like info you should have shared…

Finally, there is a bug filed: