ERROR @wdio/appium-service: Appium exited before timeout

can anyone tell me what is the reason for this. Thanks in advance

I have the same problem, installed appium globally and locally. Nothing helped. Most of the times when this happens the port stays busy and I have to kill the process manually to be able to run Appium or the tests again.

I have the same problem as well, any idea what it causing this error?

I’m also having this issue, struggling to figure out a solution. did anyone manage to figure out what was causing it.

Apparently there is no solution in sight for this:
I’m using Appium and WebDriverIO for automated testing on an Android device. After a test run completes successfully, the Appium server does not seem to release the port it was using (port 4725), according to netstat -aon | findstr 4725 . The port remains in a LISTENING state. When attempting to run another test, it fails with a ECONNREFUSED error for port 4725 , indicating it cannot connect to the Appium server. Oddly enough, if I wait a bit and try again, the first test will pass but subsequent tests fail with the same error, suggesting any second test consistently fails due to the port being occupied.

Hi all,

Do you see this behavior only with the @wdio/appium-service, or also when starting a separate server and not using the service?

Had the same error where the Appium Server do not appear to release the port it was using (port 4723). So first time running your test cases works but when you try again you get an error: ECONNREFUSED error for port 4723. To run test cases you had to run: netstat -ano|findstr “PID :4723” and then taskkill /pid 21756 /f.
Fixed by amending wdio.conf.js:

  1. Add appium:noReset and appium:newCommandTimeout as below in wdio.conf.js

capabilities: [{

    'appium:deviceName':'Pixel 3',
    'appium:newCommandTimeout': 240,
    'appium:app': path.join(process.cwd(),'app','android','ApiDemos-debug.apk')
  1. Change the services to:
    services: [
    args: {
    command: ‘appium’