Exception while starting server.A new session could not be created. (Original error: Could not initialize ideviceinstaller; make sure it is installed and works on your system

I am getting “Could not initialize ideviceinstaller; make sure it is installed and works on your system”.

I have already installed ideviceinstaller and it is running fine through command line. But while starting through java program it is giving above error message.

Below commands I have used for installing ideviceinstaller.

brew install -v --fresh automake autoconf libtool wget libimobiledevice

brew install -v --HEAD --fresh --build-from-source ideviceinstaller

The command I am using is:
/Applications/Appium.app/Contents/Resources/node/bin/node /Applications/Appium.app/Contents/Resources/node_modules/appium/bin/appium.js -p 4785 -U XXXXXXXXXXXXXXXXXXXXX --command-timeout 120

Build info: version: ‘2.48.2’, revision: ‘XXXXXXXXXXXXXX’, time: ‘2015-10-09 13:08:06’
System info: host: ‘XXXXXXXXX’, ip: ‘XXXXXXXXX’, os.name: ‘Mac OS X’, os.arch: ‘x86_64’, os.version: ‘10.11.1’, java.version: ‘1.8.0_65’

Seems like you need to add it to $PATH.

i am also getting same issue :- it’s working fine we manually perform start/stop operation but while handling server through commandline ideviceinstaller error massage displayed. if someone resolve it please help


I am new to appium ios.
Even I am getting same error. Please can anyone help to provide a solution for same.

Thanks in advance.

It may help you.

Thanks for immediate response. I am getting below path from above command :

Please suggest ahead.

Try to do the rest:

Right click on the execution.java file in Eclipse then choose [Run Configuration]

Click to tab [Environment] then click on [New]

Name: PATH
Value: /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/Library/Java/JavaVirtualMachines/jdk1.8.0_101.jdk/Contents/Home:/Users/admin/Downloads/apache-maven-3.3.9/bin:/Users/admin/Downloads/android-sdk-macosx/tools

Apply then run

Hi ,

I have tried same steps , but still getting same error. Please suggest.
PFB screenshots for same :

IF you are sure ideviceinstaller was installed, please change the path value to:


Please give a try.

Still getting same error.

May I have the full appium log file?
The appium log file, not the console output from IDE.

From which location I will get appium.log file? I am not getting the same.

If you run appium sever from GUI, go to general setting and fill in the location for log file.

If you start appium server from command line, please add:

–log /path/to/appium.log

I never use the IDE console output for debugging. With full appium log file, the guys around can take a look easier about what is actually going on.

We are starting appium server using java script.
We are also new to mac, and not able to find where is the log file being saved (location : /path/to/appium.log). :-!

Replace that one to be the real path on your mac. Anywhere you can access to.