Failed to start an Appium session, err was: Error: Bad app

Using Appium 1.3.7 on a mac with an iphone

info: [debug] Zip archive tested clean
info: [debug] Unzip successful
info: [debug] Got configuration error, not starting session
info: [debug] Cleaning up appium session
error: Failed to start an Appium session, err was: Error: Bad app: /Users/me/Documents/test.ipa. App paths need to be absolute, or relative to the appium server install dir, or a URL to compressed file, or a special app name. cause: App zip unzipped OK, but we couldn’t find a .app bundle in it. Make sure your archive contains the .app package and nothing else

However the app path is absolute. I’ve tried to load the ipa to the iphone through iTunes and that works. The app loads and launches. What could be wrong?

EDIT: Tried on an ipad and same thing happened.
EDIT 2: I looked at the location that Appium unzips the ipa and the Payload folder only has the .app file and (.ds store).

You don’t give much info, but here’s a shot in the dark: Is there a space in the .app name? If so try without.

There is no space “/Users/me/Downloads/test.ipa”

HI Cnotgo,

I think appium is unable to access your app with given path , do one thing rename your app with .app and check your app is accessible using “Go to Folder”

if app is accessible than I believe it will work.

I’m able to access the unzipped ipa with the .app file. “/Users/me/Documents/test_payload/”
However Appium still gives me the bad app error.

Could you read my question again, because that is not what I asked.

No spaces the app is “” inside the ipa.

Are you sure that the ipa is in the right path? You’ve posted 2 different paths so I’m concerned that it might not be set correctly. They are very similar.

Yes, same app in two different places.

The problem doesn’t occur when I use an iPhone 6. I was using an iPhone 4 previously.

Could you post or attach the full log of one of the failures? I’d like to look over the whole thing.

I swapped devices from iPhone 4 to iPhone6 and now it works.