Fatal Error: Could not parse version to test against: '0'

Hi All,

I installed Appium 2.0 and tried to install the drivers as below to automate the connected devices.

But after trying to install the driver for LG webOS . the install was successful D. But afterwards Appium is not working and shows the below error.

Fatal Error: Could not parse version to test against: '0’
at NPM.getLatestSafeUpgradeFromVersions (/opt/homebrew/lib/node_modules/appium/node_modules/@appium/support/lib/npm.js:166:15)
at NPM.getLatestSafeUpgradeVersion (/opt/homebrew/lib/node_modules/appium/node_modules/@appium/support/lib/npm.js:129:19)
at DriverCommand.checkForExtensionUpdate (/opt/homebrew/lib/node_modules/appium/lib/cli/extension-command.js:581:22)
at /opt/homebrew/lib/node_modules/appium/lib/cli/extension-command.js:131:25
at spinWith (/opt/homebrew/lib/node_modules/appium/lib/cli/utils.js:41:12)
at DriverCommand.list (/opt/homebrew/lib/node_modules/appium/lib/cli/extension-command.js:121:5)
at DriverConfig.getListData (/opt/homebrew/lib/node_modules/appium/lib/extension/extension-config.js:244:22)
at DriverConfig.getGenericConfigWarnings (/opt/homebrew/lib/node_modules/appium/lib/extension/extension-config.js:315:24)

Please let me know how to resolve this fatal error.Being blocked due to this.

I tried all possible ways to resolve the same like uninstall the node from homebrew. Uninstal/Install homebrew and installing node/npm again.But no luck.

Note : From terminal i am trying to launch Appium and all the drivers are installed from cli only.

@wreed . please help

Please create an issue at https://github.com/appium/appium/issues
Perhaps, the current behaviour could be improved (e.g. a better error message could be shown)

Also describe all the CLI commands used to reproduce the error

Why install every driver? Do you really need all of them? I agree w/ @mykola-mokhnach you should file a bug, but I wonder if you just installed the driver(s) that you need if everything would work.

Driver path is. : https://github.com/sharkyStudy/appium-webos-driver

Appium version used : Appium 2
@mykola-mokhnach @wreed I used " appium driver install --source=npm appium-webos-driver " command to install the driver.after that the above mentioned error is seen on trying to run appium from cli.

Before to that i installed nearly 7-8 drivers w.r.t different platform and all were working and appium was running.

@wreed , yes it was need to me,But unfortunately after the webOS drivers things broke up .
Issue arises after webOS drivers installed from the path mentioned in the comment.

@mykola-mokhnach , I will report a bug and let you know the bug ID in sometime

Bug link @wreed @mykola-mokhnach

@wreed @mykola-mokhnach i see the fix #17666 has merged in the master.Any idea when it will be available through NPM installer package?

I am trying to install appium from source but on trying to give the last command “node .” ,i am facing the below error.
any suggestions?

raja.subudhi@YFYTXJ24VR appium % node .
throw err;

Error: Cannot find module ‘/Users/raja.subudhi/Desktop/appium-source/appium’
at Module._resolveFilename (node:internal/modules/cjs/loader:995:15)
at Module._load (node:internal/modules/cjs/loader:841:27)
at Function.executeUserEntryPoint [as runMain] (node:internal/modules/run_main:81:12)
at node:internal/main/run_main_module:23:47 {
requireStack: []

commands used:

git clone https://github.com/appium/appium.git
cd appium
npm install
npm run build
node .

The patch will be available after the next beta is published

1 Like