Fruitstrap quit unexpectedly when I tried to launch safari on real device

Hi everyone,

I was trying to launch safari and do some testing on real device. When I ran my test, I always get “fruitstrap quit unexpectedly” popped out like this:

Here is the error (MY_DEVICE_UDID represents my iphone udid):
org.openqa.selenium.SessionNotCreatedException: A new session could not be created. (Original error: Unable to install [/var/folders/y1/qs7n7tb92c15ltn3y0ksfjkc002rd1/T/116117-65663-khwwkw/submodules/SafariLauncher/build/Release-iphoneos/] to device with id [MY_DEVICE_UDID]. Error [Error: Command failed: /bin/sh -c /Applications/ install --id MY_DEVICE_UDID --bundle "/var/folders/y1/qs7n7tb92c15ltn3y0ksfjkc002rd1/T/116117-65663-khwwkw/submodules/SafariLauncher/build/Release-iphoneos/" ]) (WARNING: The server did not provide any stacktrace information)

Here is my settings:

DesiredCapabilities capabilities = new DesiredCapabilities(); capabilities.setCapability(MobileCapabilityType.PLATFORM_NAME, "iOS"); capabilities.setCapability(MobileCapabilityType.PLATFORM_VERSION, "8.3"); capabilities.setCapability(MobileCapabilityType.DEVICE_NAME, "iPhone"); capabilities.setCapability(MobileCapabilityType.BROWSER_NAME, "Safari"); iosDriver = new IOSDriver(new URL(, capabilities); iosDriver.manage().timeouts().implicitlyWait(60, TimeUnit.SECONDS); return iosDriver;

I followed every step in this instruction: Mobile Web automation on iOS real device – Safari except ./bin/ios-webkit-debug-proxy-launcher.js -cMY_DEVICE_UDID -d
because I got error:
throw err;

Error: Cannot find module ‘underscore’
at Function.Module._resolveFilename (module.js:337:15)
at Function.Module._load (module.js:287:25)
at Module.require (module.js:366:17)
at require (module.js:385:17)
at Object. (/Users/olivia/Documents/appium/bin/ios-webkit-debug-proxy-launcher.js:22:9)
at Module._compile (module.js:435:26)
at Object.Module._extensions…js (module.js:442:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:311:12)
at Function.Module.runMain (module.js:467:10)`

I am not sure if this is related.

Can someone please help? Thanks ahead!!

I wonder what version of Appium you are using? Fruitstrap has not worked for a while now. Current versions use ideviceinstaller.


Thanks for the reply!

I was using appium 1.3.6.


How do you feel about updating to the latest? Is there some reason that you haven’t?