Gem install appium_console Error

Trying to install Appium Console, get this error message:

ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
bad response Not Found 404 (

Try gem install pry

I get this error then

ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
bad response Not Found 404 (

What is the output from: gem environment you may have an old gem environment that needs to be updated. If you don’t have ‘’ in your sources you might add it with:

gem sources -a

If you can find the gems with your browser and download them you can run this to install them without needing to fetch them from the internet. If the file name you get is pry-0.10.1-x86-mingw32.gem

gem install --local pry-0.10.1-x86-mingw32.gem

I get this for environment:

RubyGems Environment:

  • RUBY VERSION: 1.9.3 (2014-11-13 patchlevel 551) [i386-mingw32]
  • INSTALLATION DIRECTORY: C:/Ruby193/lib/ruby/gems/1.9.1
    • ruby
    • x86-mingw32

I downloaded the gem with gem fetch
But the trying to install it I get the same Error 404 message

And when I do this gem install --local pry-0.10.1-x86-mingw32.gem I get:
Could not find a valid gem ‘pry-0.10.1-x86-mingw32.gem’ (>= 0) in any repository

You may need to be on a newer version of Ruby, this could be the problem. You can use rvm to install another Ruby on your machine. I haven’t used Ruby on Windows in a long time but I seem to remember that we were using the ming version.

Ruby 1.9.3 is too old and will be EOL soon, please update to the latest stable version of Ruby.

Thx, installing last version of Ruby solved it!

Hi Vladimir,

Which version of Ruby did you install? Thanks.