Having issues with clicking elements in webview

i’m switching to the webview, finding the elements by their id’s and clicking on it. the click does not give me an error since the elements are visible. However, no action happens after the click which means that the element has actually not been selected. Please help me in figuring out where i’m going wrong.

Try to use xpath taken from chrome remote debugger
When u right click over HTML in chrome remote debugger it says copy XPATH use that xpath and see if it works


my problem is solved. But i specifically needed ids and not xpath.

What is the actual issue you have faced with??

the issue was with my chromedriver. it wouldnt click on the elements despite locating them.

How did u came to conclusion that issue is with chromeDriver itself ?
How did u fixed it … like u updated chromeDriver.exe version which appium uses internally ?

i used chromedriver executable capability to point to the chrome driver version i wanted. That helped since the switching to webview context would not happen a lot of times. Apart from that i used a different url in my code. That helped too. i dont know why though