How to push picture to IOS real device Photos?

Hi, I want to add a photo from my laptop to an iOS real device native APP Photos during the appium test. I manage to do so for android with following push file command:
driver.pushFile("/mnt/sdcard/Automation/demophoto.png", imageFile);
I have also found instructions for iOS simulator. But when I try this on a iOS real device, I tried
driver.pushFile("demophoto.png", imageFile);
The command seems to be executed, but nothing shows up in the Photos app.

Most instructions I can find only is to address the problem to push file into some app container.
https://github.com/appium/appium/blob/master/docs/en/writing-running-appium/ios/ios-xctest-file-movement.md
I find the bundle ID for Photos from this link: https://emm.how/t/ios-13-list-of-default-apps-and-bundle-id-s/1141, and tried appDriver.pushFile("@com.apple.Photos/demophoto.png", imageFile);
get this error message:
org.openqa.selenium.WebDriverException: An unknown server-side error occurred while processing the command. Original error: Failed to vend into the application container. Error: InstallationLookupFailed

Does anybody know what’s the right way to do this?

I assume such feature is restricted on real devices by Apple. Adding an image to photos app is not only about adding a file to a folder, but its metadata should also be added to the internal database.

Hello
I am new to Appium could someone please help me on below test:

trying to copy image file from my project/ resources to IOS real device Files folder
below is my code
File img = new File(assetDir.getCanonicalPath(),“sampletextfile”);

System. out .println("file img is "+img);

driver .manage().timeouts().implicitlyWait(3, TimeUnit. SECONDS );

((IOSDriver) driver ).pushFile("@com.apple.DocumentsApp/"+img.getName(), img);

Below is the error from Appium logs:
Calling AppiumDriver.pushFile() with args: ["@com.apple.DocumentsApp:documents/sampletextfile",“dGVzdCBkcml2ZXIucHVzaGZpbGU=”,“ee149444-75ae-40ac-8d6a-9c892e22bf81”]
[XCUITest] Executing command ‘pushFile’
[XCUITest] Parsed container type: documents
[W3C (ee149444)] Encountered internal error running command: Error: Failed to vend into the application documents. Error: InstallationLookupFailed
[W3C (ee149444)] at HouseArrestService.vendDocuments (/Applications/Appium.app/Contents/Resources/app/node_modules/appium/node_modules/appium-ios-device/lib/house-arrest/index.js:68:13)
[W3C (ee149444)] at createAfcClient (/Applications/Appium.app/Contents/Resources/app/node_modules/appium/node_modules/appium-xcuitest-driver/lib/commands/file-movement.js:37:12)
[W3C (ee149444)] at createService (/Applications/Appium.app/Contents/Resources/app/node_modules/appium/node_modules/appium-xcuitest-driver/lib/commands/file-movement.js:64:21)
[W3C (ee149444)] at pushFileToRealDevice (/Applications/Appium.app/Contents/Resources/app/node_modules/appium/node_modules/appium-xcuitest-driver/lib/commands/file-movement.js:254:35)
[W3C (ee149444)] at XCUITestDriver.pushFile (/Applications/Appium.app/Contents/Resources/app/node_modules/appium/node_modules/appium-xcuitest-driver/lib/commands/file-movement.js:478:7)
[HTTP] <-- POST /wd/hub/session/ee149444-75ae-40ac-8d6a-9c892e22bf81/appium/device/push_file 500 169 ms - 831

@xckang @mykola-mokhnach could you please let me know the alternative for this issue

For Android am able to push the file but for IOS real device am unable to . do I need to set anything

@Aleksei @KazuCocoa
could you guys please help me on this. I have installed macfuse, fuse unable to install ifuse.

never used. doc is here -> http://appium.io/docs/en/writing-running-appium/ios/ios-xctest-file-movement/

Thank you @Aleksei , I have followed the doc but unable to install ifuse am getting error ifuse is disabled requires fuse . In my system though macfuse and fuse were already installed.

Do I need to install any dependencies for this or any set up ?