How to resolved the incompatible problem between appium-dotnet-driver and selenium driver 3.13.0


Our team have a C# automation framework, the selenium driver version of this framework is 3.13.0. I need to integrate Appium driver to this framework. I used the latest stable Appium driver version (, but it is incompatible with selenium driver 3.13.0, it throws below error when initializing driver(iOSDriver driver = new IOSDriver(serverUri, cap, TimeSpan.FromSeconds(1800))):
‘Method ‘Dispose’ in type ‘OpenQA.Selenium.Appium.Service.AppiumCommandExecutor’ from assembly ‘appium-dotnet-driver, Version=, Culture=neutral, PublicKeyToken=null’ does not have an implementation.’

It is working well if I downgrade the selenium driver to 3.12.1, but downgrading selenium driver is not feasible in existing framework as too many dependencies. I also tried all other versions which are higher than 3.13.0, but they(3.13.1, 3.14.0 and 3.141.0) are not working either.

Does anyone have solution about this or any suggestions ? Thanks.

Ps. I also tried Appium driver beta version , it does not work too, there are following problems

did you solve yours because I have the same issue
please if yes, tell me how