How to setup Appium for IOS 13

Hi Experts

if someone is already using appium for IOS 13 , please share the setup that you did :

  1. Appium version (link or version number)
  2. web driver agent version (link or version number)
  3. Xcode version ( I know that 11 is needed for IOS 13.x and I have 11.1 installed)

I currently run automation on IOS 12.x and I couldn’t activate it on IOS 13.x device no matter which Appium or web driver agent I used .

Thanks in advanced


I have used version 1.15.0 and the latest beta. I had no issues running tests on IOS 13.1 real device.

Can you please elaborate more on the issue ur facing?

after upgrading to appium 1.15.1 to support ios 13.x I received the following error from appium server : [Xcode] 2019-10-27 12:17:52.313 xcodebuild[2380:19204] iPhoneConnect: :iphone:<DVTiOSDevice (0x7ff9fde90d40), Testphone, iPhone, 13.1.2 (17A860), 9324412f46d9b78c50aa43955e0e0458928c04b3> unable to mount developer disk image, (Error Code=601 “Could not locate device support files.” UserInfo={DeviceType=iPhone8,1, NSLocalizedDescription=Could not locate device support files., NSLocalizedRecoverySuggestion=This iPhone 6s is running iOS 13.1.2 (17A860), which may not be supported by this version of Xcode.})

did you encounter this error?
can you elaborate on the setup that you did(webdriver agent,xcode version)?

The error message says that you need to upgrade to newer version of Xcode.

Hi Tor

thank you for your answer . Im running Xcode Version 11.1 (11A1027) which is the latest one in the App store . do I need to update to the Beta version (11.2) ?

You should be able to download the device support for iOS 13.1 here:

thank you very much Tor​:+1::+1::+1:

Hi Tor

after doing so , the appium server generated the same error . I had to roll back to xcode 10.3 in order for the appium server and to support ios 12.4 .
can tell me the update steps you did for running the automation on 13.x(xcode , appium , device supprt ,etc’) ?

I actually made a clean install of macOS, Appium and Xcode.
I never had to update device support manually.

which Xcode and Appium versions do you use ?

Appium 1.15
Xcode 11.1

thanks :slight_smile:

last questions :
which version did you download from:

which webdriveragent did you download from:

I didn’t download any driver support. My guess is that it was included in Xcode?
I didn’t install WebDriverAgent separably but followed this guide:

(With some small modifications for Appium 1.15)

thanks :slight_smile:
as far as I understand ios 13 isnt fully supported for now .
I will continue to follow when its fully supported .

thank you very much for the info .


With iOS 13.2.2 and appium version 1.15.1 I’m facing below error. Any help would be appreciated.

Could not proxy command to remote server. Original error: 302 -

It’s been 20 days I’m unable to launch app on iOS the device. I changed Appium version, Xcode Version, almost everything the forum suggests, but no help. App gets installed on device, webdriver agent also gets installed without any error. But it will not launch the app, I get below error all the time.
“Could not proxy command to remote server. Original error: 302” on Appium 1.13. In Appium 1.15 If I try running, I get “Proxying [GET /status] to [GET http://localhost:8100/status] with no body” and this message continues to come and app will not be launched.
Please someone help me.

I have the following issue with Appium 15.1 and 16.0 with Xcode 11.3.1 and iOS 13.2
If I run Appium app and do Inspection Session, everything works fine. No issues.
However, if I run my tests from Intellij Idea (where everything is working for iOS 11 and iOS 12) it simply said : No device connected.
Can someone help me to understand why Appium can see the device, but Intellij Idea cannot?