How to upgrade the chromedriver associated with Appium?

I am doing automation on a hybrid app on Android. To automate some objects, I need to context switch the driver to iFrame. While doing that , I am facing the below error
org.openqa.selenium.WebDriverException: unknown error: call function result missing ‘value’
(Session info: chrome=65.0.3325.109)
(Driver info: chromedriver=2.33.506106 (8a06c39c4582fbfbab6966dbb1c38a9173bfb1a2),platform=Mac OS X 10.12.6 x86_64) (WARNING: The server did not provide any stacktrace information)

I did look up and it seems to be a compatibility issue of chrome driver 2.33 with google chrome version 65. As per the suggested solution, I did download the latest chrome driver 2.37 and have also set my PATH in the bash_profile( I am using MAC with MacOS Sierra) to the latest chromedriver. However, appium refuses to take the latest chromedriver and still works with the old one. I also tried the layman’s solutions of restarting the system, re loading the environment variables etc to no luck.

How can we make appium pick up the latest chromedriver?

think this will fix it

npm install appium-chromedriver --chromedriver_version=“2.37”.

Trying it out

That did not fix it, appium says my chromedriver is still 2.33.Can anyone please help?

1 Like

you can try downloading from
and replace in your local folder

1 Like

I ran into the same issue and found this solution.

Download the latest chromedriver manually from:
Then you can do stuff like this to use the manually downloaded chromedriver instead of the one appium uses by default.
appium --chromedriver-executable ~/downloads/chromedriver

1 Like

@mark0203 : Thank you!!! I did “appium --chromedriver-executable ~/downloads/chromedriver” while starting the appium server and it did work :slight_smile: