I am trying to find an element in a collection view

I have put in automation Id for this by binding in the developers code with the names being the same like foo has an autoamtionid as foo but appium is not able to see down this far… When I go to appium inspector it highlights the entire collection. I have tried using xpath return MobileBy.XPath("//IOS.widget.ListView[contains(@text=‘foo’)]")); this is not working for me. when I click on the xpath from inspector I see XCUIElementTypeOther and the same ios class chain.

there is no ‘text’ attribute in ios

what should i use instead?

using ListView is difficult because Appium inspector does not show anything for these and I am not familiar with how to work with these views.

depending on how your dev writing code this is most probably “value”.

When I use inspector it shows a block of the list. I tried to go to the code and change each automation tree to false but it did not do anything. Is there another way for value to work?

sorry did not understand above. provide example.

I have a list that has phases of the moon

Waxing Crescent
First Quarter

When I hoover over this with Appium Inspector the entire List shows as one element. I need it to show as individual elements so I can click on just new or Waxing Crescent or First Quarter. When I click at New the entire list is highlighted and this blob it shows as xpath XCUIELementTypeOther. I have another list doing the same thing.

Can you see list elements in xCode ‘Accessibility inspector’ ?

I hope I am answering this correctly but the application is not developed using xcode. I only used for the webagent. Should I try to see if xcode can see that as accessible?

ok. maybe app has webView? try also ask app developer for help.

I have asked the dev but he is not an Appium expert. I have made some changes in xamarin collections by making the Automation tree accessible to False but it does not appear to have fixed anything.

After looking over the Dev code it looked as though this change had not been completed. Add the below to Carousel,collection or list views.

This fixes the issue of it being one giant block. I wanted to ensure its in the forum in case anyone else runs into the issue.