I Cant fix this

Unable to create a new remote session. Please check the server log for more details. Original error: An unknown server-side error occurred while processing the command. Original error: Unable to launch WebDriverAgent because of xcodebuild failure: xcodebuild failed with code 65

how you tried fix this?

See many documentation but cant fix the problem.I am using eclipse, java, appium .

write down what exactly you did. e.g. did you build WDA? without your info we cant help you.

i do this documentation but show this but show no such file or directory

Solved :smiley:

Following steps worked for me…

Cd usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent
brew install carthage
npm i -g webpack
./Scripts/bootstrap.sh -d

open /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/
run project

And solved sign in error with config file.

Thanks a lot… :bouquet:


If you get a error like "error: /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/Resources/WebDriverAgent.bundle: No such file or directory "

do this in terminal and then clean > build webdriver agent project in xcode.

mkdir -p /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/Resources/WebDriverAgent.bundle

all you was needed is just follow official guide. which include your steps. -> http://appium.io/docs/en/drivers/ios-xcuitest-real-devices/

I fix this in Simulator but in real device its give below error:
Showing All Messages

Failed to register bundle identifier: The app identifier “com.androidiostesting1.WebDriverAgentRunner” cannot be registered to your development team because it is not available. Change your bundle identifier to a unique string to try again.

No profiles for ‘com.androidiostesting1.WebDriverAgentRunner’ were found: Xcode couldn’t find any iOS App Development provisioning profiles matching ‘com.androidiostesting1.WebDriverAgentRunner’.

Thanks Fixed this issue