I can't get Appium Swipe keyword to work in Mac

I recently switched devices from windows to mac. I have setup robotframework, Appium, Python on my system. However, when I run the tests, it looks like swipe action does not work anymore. It does not show any error, as it simply does not swipe.

However, the same code, if tried in my windows system which I was working previously, it works perfectly there. Here are the versions installed:

Package Version Appium-Python-Client 2.11.1 robotframework 6.1.1 robotframework-appiumlibrary 2.0.0 robotframework-archivelibrary 0.4.2 robotframework-assertion-engine 3.0.3 robotframework-browser 18.3.0 robotframework-oracledb 2.0.2 robotframework-pabot 2.18.0 robotframework-pythonlibcore 4.4.1 robotframework-requests 0.9.7 robotframework-seleniumlibrary 6.2.0 robotframework-stacktrace 0.4.1

Here is the sample code: `

${Sign} = Wait Until Element is Visible. id=ch.post.it.nemo.app.zust.android.next:id/saveImageButton_portrait
IF ${Sign}
bi.Wait Until Keyword Succeeds 10 sec 0.5 sec Swipe By Percent 90 90 80 30
bi.Log To Console ||–Page is not displayed–|| console=yes END`

Any swipe keyword including Swipe, Swipe By Percent.

Could you please help resolve this issue?

Thank you in advance :slight_smile:

I did try to match the Appium-Python-Client,robotframework, robotframework-appiumlibrary versions (which you see above) with the versions which was on windows. It still did not work. I am wondering what else might be the cause