I click an element without seeing the effect

[Appium] [IOS 9.0] [Simulator iPhone 5s]
I’m automating the tests of an application which has a lot of web views, and I have this problem with clicking a date type input which supposed to invoke a Date picker.

Here is the script I’m talking about:
WebElement expiryDate = driver.findElement(By.id(“expiryDate”));

When I debugged the script and execute the script step by step, Appium succeed in clicking the expiryDate without any visual effect (I mean the datePicker doesn’t appear) and I fail on the next step which is choosing the date from the picker wheel (cause there is no date picker wheels).

I’ve tried:
WebElement expiryDate = driver.findElement(By.id(“expiryDate”));
driver.executeScript(“arguments[0].setAttribute(‘value’,‘2017-09’)”, expiryDate);
But with out any result.

When I tried to do it on the native context, surprise, the element doesn’t appear neither in Appium inspector nor in the source code of the page. her is a snippet from the source code.

     <UIAStaticText name="Date d&apos;expiration" label="Date d&apos;expiration" value="" dom="[object Object]" enabled="true" valid="true" visible="true" hint="" path="/0/0/17/1/2" x="36" y="207" width="115" height="21">
                <UIAStaticText name="Cryptogramme" label="Cryptogramme" value="" dom="[object Object]" enabled="true" valid="true" visible="true" hint="" path="/0/0/17/1/3" x="196" y="207" width="102" height="21">

I see the label, but I don’t see the date input.

I’ve did the tests using the latest version of Appium (1.5.2) and Appium version 1.4.13.

did you try using Xpath instead of ID?

This sounds like a job for implicit waits:

I’ve tried in my script an explicit wait, but it doesn’t change any thing.

What about an implicit wait?

I’ve tried it, and it doesn’t solve the problem

Hi i am also facing the same problem, did you get any solution for it ?

Would appreciate if you could share your solution.