INSTRUMENTATION_FAILED error when running test

Hi guys!

Still have this error on one environment. Here are the details.
Click me

Also I tried to do all sett up from scratch on third environment and it works good.

I’ve tried to run on this broken environment on real device and it also works.

The problem that exactly this broken environment its our test qa environment on which all CI tests should work.

Any suggestions how to resolve this??

No ideas at all? ((((((

I have the some issue when I use Selendroid for automation. I spend 2 days and not found a solution.
Any verified ideas ?


I faced many difficulties while running appium in selendroid mode… The workarounds which worked in my cases.

  1. Try to delete rm -rf /tmp/*.apk
  2. reverted appium version 1.0.0, this is becasue it is uses selendroid 0.9.0. which worked well in my case.

Priyank Shah

I tried both variants and it didnt help me ( - tried appium 1.0.0,, 1.1.0, 1.2.0, ((

Have you got any solution ?

If yes then please let me know.

Actually what I did is not a solution i think but may be as workaround.

I tried a lot of scenarios and no success.
My last thought was that something wrong with environment - I checked all settings, re installed all several times - nothing.

Than I formatted drive C: and re installed again. After that it works fine without problems. This was my last hope )
I spent really a lot of time for investigating this.

Probable Workaround:
I tried launching apk with selendroid jar file using this command :C:\Users****\Downloads>java -jar selendroid-standalone-0.15.0-with-dependenci
es.jar -app path_of_apk_file

It created a new file with is like resigned_nameoftheapkfile on the same place where your original apk is present.

Then I used newly created resigned apk file and then the issue got