Instruments keeps launching last used device Simulator

Hi there,

I use Appium to automate my tests on both the iPhone Simulator and the iPad Simulator (for this case it doesn’t matter which exact device name I use).
When I run my test on the iPad Simulator after having it run on the iPhone Simulator (and vice versa) Instruments appears to keep launching the first device I run my test on.
The Appium log says it is starting the right device and then starts Instruments as follows:

info: [debug] Spawning instruments with command: /Applications/ -t /Applications/ -D /tmp/appium-instruments/instrumentscli0.trace -w “iPad 2 (8.1 Simulator)” -e UIASCRIPT “/Users/bluebillywig/Library/Application Support/appium/bootstrap/bootstrap-babf13f50b400846.js” -e UIARESULTSPATH /tmp/appium-instruments

I read that when I want to run this command I should have -w and the device name first. When I tried this by launching instruments myself in the terminal ( instruments -w “iPhone 6 (8.1 Simulator)” ) the Simulator started the right device and after my test would run on the right device as well. I have to add, though, hat after a while I would have the same issue with the Simulator launching the same device every time.

Does anyone have an idea what I can do about this?

Thanks in advance,


to give you a better idea: