iOS 9 simulator not launching after upgrading to El Capitan

Hi folks,
I have the following set up
Appium 1.4.13
Xcode 7.1 / 7.2
OS X El Capitan 10.11.3
iOS Version 9.1
iOS Simulator iPhone 5s

When ever I am runing the script to launch the simulator, I am getting the following message “Instrument crashed on start up”.
However, the same set up with xcode 6 and iOS 8.4 and iPhone 5s works perfectly fine on El Capitan and Yosemite.

Has any one encountered any issues after upgrading to El Captain or if you can point me into the right direction?
Any help is highly appreciated.


Correlation does not imply causation. I always ask the stupid questions so forgive me, but you don’t mention whether you have tried opening Xcode and starting the Simulator manually. If not, try it. If it doesn’t work, delete the Simulator and make a new identical one. If it still doesn’t work, delete Xcode and reinstall it, add the 8.4 SDK and recreate. I think it will work at that point.

The solution suggested doesn’t work.
However, installing xcode 7.3 beta witht Appium 1.4.13 on El Capitan work and gives access to a range of verisons from 9.1 to 9.3

My suggestion is not to upgrade to El Capitan unless as yet.