IOS App getting installed in simulator but it wont open


#1

I already setup all requirements needed for the appium and i already got the .ipa file which has the developer provisioning profile but everytime i run it on appium it still wont open. I’m not sure if i got the correct desired capabilities setup for appium desktoo.

I’m getting below error:
SONWP Proxy] Got response with status 200: {“value”:“Failed to launch nz.co.telecom.TNZSmartphone.beta.dev application”,“sessionId”:“F07E0D7E-969F-4CC1-BBB1-C19ABA2AEBDF”,“status”:13}
[XCUITest] Failed to create WDA session. Retrying…
[BaseDriver] Event ‘wdaSessionAttempted’ logged at 1496360482667 (11:41:22 GMT+1200 (NZST))
[XCUITest] Sending createSession command to WDA
[JSONWP Proxy] Proxying [POST /session] to [POST http://localhost:8100/session] with body: {“desiredCapabilities”:{“bundleId”:“nz.co.telecom.TNZSmartphone.beta.dev”,“arguments”:[],“environment”:{},“shouldWaitForQuiescence”:true,“shouldUseTestManagerForVisibilityDetection”:false,“maxTypingFrequency”:60,“shouldUseSingletonTestManager”:true}}


#2

M Also Facing the same. App trying to launch

BaseDriver] Event ‘wdaSessionAttempted’ logged at 1496483280036 (15:18:00 GMT+0530 (IST))
[XCUITest] Sending createSession command to WDA
[JSONWP Proxy] Proxying [POST /session] to [POST http://localhost:8100/session] with body: {“desiredCapabilities”:{“bundleId”:“com.venuIq.ffldn17”,“arguments”:[],“environment”:{},“shouldWaitForQuiescence”:true,“shouldUseTestManagerForVisibilityDetection”:false,“maxTypingFrequency”:60,“shouldUseSingletonTestManager”:true}}


#3

We were able to idetified the issue behind and it’s not the desired capabilities that causing the problem, it was the .ipa file given. The dev team make a new build which only for simulators.

If you found the same below error on the system logs then ask the developer to give you new .ipa build.

]: Error: Could not create service from plist at path: file:///Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk/System/Library/PairedSyncServices/com.apple.pairedsync.tccd.plist. Returning nil PSYSyncCoordinator for service name com.apple.pairedsync.tccd. Please check that your plist exists and is in the correct format.


#4

I am describing my problem in below steps.

  1. WebDriverAgent is installing on my simulator. In appium logs I am getting-WebDriverAgent running on ip ‘192.168.xx.xx’.
    XCUITest] WebDriverAgent successfully started after 30066ms
  2. Now XCUITEST is sending creatSession command WDA.
  3. WebDriverAgent is installed in my simulator.
  4. .ipa application is also installed after running.
  5. Now On simulator WebdriverAgent is launching for a while then again goes back on home screen.
  6. Now my .ipa application is launching for a while and its also goes back on home screen.
  7. In the appium logs we are getting “Failed to launch application.”

I have tried many ways to overcome this problem but after so hard work we still stuck on the same issue. Please also refer the screenshot of appium logs.


#5

Are you able to launch app manually? I think .ipa file don’t work in simulator, for simulator you need .app file.


#6

I tried both .ipa and .app file. But did’nt work. Looking for the solution


#7

Hello all,
Any solution found for this? I am still facing this issue.
I am using xcode 9.3.1 and appium 1.8.0.


#8

Hi all,
I am also facing the same issue now does anyone has the solution for this ?. If so then revert back

thanks!


#9

Though both looks same to me but this may be the solution :

https://code.i-harness.com/en/q/1f35f9b

or