iOS - [BaseDriver] The following capabilities were provided, but are not recognized by appium: appium-version, xcodeConfigfile, xcodeOrgId, xcodeSigningId [SOLVED]

macOS Sierra version 10.12(16A323)
Appium v1.6.3
Xcode Version 8.0

Cannot execute test in a real device.
I can execute in real device when app is installed manually.
But when it is let to install with script, it does not install app.

My script is as follows…

I had a similar issue, then I restarted my machine and ran again then it worked.

Something is wrong with ios - deploy …

Thanks for response.
If you find any other solutions plz let me know… :neutral_face:

when i set the xcodeOrgId and the xcodeSigningId in my capabilities I could get it to work either.

I used the xcodeConfigfile capabilities, and when I set up the ConfigFile I had to check Target Membership for both WebDriverAgentLib and WebDriverAgentRunner.

Once that is done run the Build the Web Agent. Next rebuild the app.

Try again and see if that works.

Would you don’t mind to put the code sample of your capabilities section please… ??

There the almost the exact same as yours.

Except I’m not using xcodeOrgId, xcodeSigningId and bundleId.

Did you build your app using the Real Device from the dropdown or did you build it with simulator?


With simulator… is there a significant difference between device build and simulator build?

I think so, when I attempted to open my real device APP on a simulator it was just opening and closing right away.

Finally solved ,

for iOS simulator use .app of the app.
Use .ipa by archive app for real device testing.

@Sandarekha Could you please explain how you resolved this?

Create your app archive.It gives you .ipa of your app.

Xcode > select generic ios device or your connected device > Product > Archive > follow steps > Then you have .ipa of your app.

Then use capabilities as follows,

capabilities.setCapability("app", "/Users/admin..../abc.ipa");

What is the issue you are facing? Are you using a simulator or device?

Thanks. I was using the ipa flag. so capabilities.setCapability("ipa", "/Users/admin..../abc.ipa"); instead of capabilities.setCapability("app", "/Users/admin..../abc.ipa"); Works now, thanks.

1 Like

If somebody still couldn’t get it working, can refer to Appium ( WDA ) setup on Real iOS Device lessons learnt & pain areas


cap.setCapability(“ipa”, “/Users/karna/Desktop/Test/karna12.ipa”);

After adding the capabilities its displaying below error. Please help me in this.

An unknown server-side error occurred while processing the command. Original error: The desired capabilities must include either an app or a bundleId for iOS (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 141 milliseconds

try this:
cap.setCapability(“app”, “/Users/karna/Desktop/Test/karna12.ipa”);