iOS device not connecting to appium

I am trying to make real iOS device work with appium. Xcode build is successful when building from Xcode. After adding capabilities to appium and initiating the session, getting below errors. The same set up works as expected with simulator. it successfully installs WDA on simulator but unable to install the same on real iOS device.

Xcode: 12.5 beta


iOS device: 14.4.2

Here are few things that I already tried:

  1. Tried doing same set up with Appium 1.18 and 1.20
  2. Tried doing same set up with Xcode 12
  3. Tried restarting multiple times
  4. Tried with adding new provisional profile
  5. Tried with different iOS devices
  6. Tried connecting device from different port and cablesappium-server-logs_latest.txt (56.0 KB)
  "bundleID": "com.gcc1.WebDriverAgentRunner",
  1. here should be bundleID of your app. NOT WDA.
  2. did you enable automation on device in developer menu?
  3. did you successfully build WDA for REAL device (not simulator) ? ->

It would be a good idea to add an ‘app:’ setting to your capabilities. Something like:

app:  /path/to/my_app.ipa

You can just give bundle id if the app will always be installed manually. You should read this:

Also try to get the character cases correct. “bundleID” != “bundleId”

#1: We tried removing it and building. It do not work.
#2: Yes. Automation is enabled.
#3: Yes WDA is build from Xcode.

So did you correct “bundleId” with correct id of app installed on phone OR provided path to “ipa” file?