IOS device pushfile

Need help in pushing files to real IOS device.
What all things should I install before pushing file.
Please help me with path for pushfile as I tried many and none of them worked.

Aleksei please help me in this

For Appium 1.15.0 and newer no additional dependencies are needed to push files to and from the device

@KJAbhilash per @mykola-mokhnach implemented ONLY for Simulator

Not really, it also works on real devices now. Also one does not need to install ifuse since Appium 1.15

@mykola-mokhnach then it will be nice to add such test into java-client :slight_smile:

Of course it would be… if one could find any CI service, that provides access to real mobile devices for free :wink:

Thanks for the reply.
I checked for the latest version of appium and its 1.14.2
When can we expect 1.15.
I read some code of push file in appium and I tried to use it and it is throwing some exception in mountdevice.
Any help on this

Installed appium desktop 1.15.1 still unable to push file to IOS device.
Received response is null after the operation.
Please help me with syntax for push file.

@mykola-mokhnach,@Aleksei was getting error as unexpected response PERMISSION_DENIED when given @bundled_id/Path_to_be_saved and getting null when the path is given only file name.
I checked in git and the same is fixed in #1018 but the same is not added in any release.
When used the IOS default apps bundleid to push file like
getting Encountered internal error running command: Error: Failed to vend into the application container. Error: InstallationLookupFailed
Can you please check once.

1 Like

@ KazuCocoa any help…!

were you able to figure out pushing files to real iOS device? my tests passes but can’t find the file