iOS elements not found from inspector

I have a container that has a bunch of videos with horizontal scrolling to the right.
Whenever I run the inspector to see their XPath and hover over them, I see the first three, but then video 4 - 6 are not there and the parent container gets selected instead.
After that video 7 - 9 again are visible in the inspector and the last 10 - 12 are not.

When i run my automation code through browser-stack i get the exact same failures on video 4 - 6. It’s like they don’t exist.

I’ve tried the “snapshotMaxDepth”: 200 capability and that started to display them in the inspector, but it still doesn’t find them from my code.

We tried accessing them by Xpath and Accessibility ID but nothing worked.
Can anyone help with this strange behaviour?

iOS: 13.5, tried both Appium 17.1 and 18.0 with the same results.

are the videos “on screen”?
One limitation of appium is it cannot ‘see’ off screen objects because it’s dumb for lack of the technical reason. So if you see the first few, and then scroll horizontal and do the query again, you should see new indexes that match the now ‘on screen’ ones. It will not remember the old ones, so if you are trying to do a ‘everything is there, okay good.’ list, you are going to have to dumb and remove redundant list items.