iOS fab button does not appear in UI when running appium

When using Appium Inspector I can see the FAB icon appear in my iOS app. When I run the tests with appium the FAB icon does not appear in the app. I have tried waiting for it to load and I have tried navigating to other parts of the app and back to try to trigger it to appear, but no luck. I also tried using a simulator via xcode and a real device via browserstack. Is there anything in the swift code that could prevent elements from being accessible/visible when running the tests in appium?

The icon on the app is really governed by the operating system, in this case iOS. My understanding is that even if the metrics for displaying this are met, it may or may not show. There is no way in Appium to show this icon, and in our case I have seen the icon on the app even when metrics are not met, usually due to reinstall of the app over and over in testing.

I don’t think these icons are reliable enough to test with automation. In manual tests they do seem a little more reliable.