iOS Tests failures after upgrading MacOS to Mojave ('RoutingHTTPServer/RoutingConnection.h' file not found)

Hi All,

Recently I’ve upgraded my MacOS to the latest Mojave version, unfortunately it somehow broke my iOS tests.

When running any iOS test I’m encountering with this error message :

Caused by: org.openqa.selenium.WebDriverException: An unknown server-side error occurred while processing the command. Original error: Unable to launch WebDriverAgent because of xcodebuild failure: "xcodebuild failed with code 65". Make sure you follow the tutorial at Try to remove the WebDriverAgentRunner application from the device if it is installed and reboot the device. Build info: version: '3.12.0', revision: '7c6e0b3', time: '2018-05-08T14:04:26.12Z'

I’ve navigated to node_modules⁩ ▸ ⁨appium⁩ ▸ ⁨node_modules⁩ ▸ ⁨appium-xcuitest-driver⁩ ▸ ⁨WebDriverAgent⁩ and opened WebDriverAgent.xcodeproj in Xcode then noticed that some files are missing ('RoutingHTTPServer/RoutingConnection.h) thus the build fails, moreover it seems that the entire RoutingHTTPServer.framework is no longer recognised by the project.

I’ve tried almost any solution on the Web

  • Followed the tutorial in the given error message
  • Uninstalled & reinstalled Appium to the latest Beta version
  • brew install carthage & ./Scripts/ -d from the WebDriverAgent folder
  • Tried resolving the build failure manually by opening the WebDriverAgent.xcodeproj in Xcode and re-attaching the missing RoutingHTTPServer/RoutingConnection.h file. Even copied the entire RoutingHTTPServer.framework

But nothing seems to be working, I would love to read any suggestion on how to solve this issue.

Macs that weren’t upgraded to Mojave are not effected by this issue.


Try this in terminal
sudo -s bash /Applications/ -d


Thanks for replying :slight_smile:

When trying the solution the terminal output is:
Run this script from the root of repository

But as mentioned I’ve already tried running ./Scripts/ -d from the WebDriverAgent folder but it didn’t fixed the problem.