Is this possible to run appium for IOS real device on window 7

I need help in setting up appium for IOS apps and using IOS real device & window 7.

Is it possible to run my app on real ios device with window 7 using appium + selenium framework?

1 Like

@newgen_appium : I would say answer is no and yes both.
No :- Because there is no Xcode available for windows 7 and without xcode you can’t use appium for IOS.
Yes :- Workaround is install VMware on windows 7 and install Mac OX on VM and use it for your appium testing for IOS devices.

1 Like

@newgen_appium, I think here is the best explanation on how to work around it:
How to use the Remote server functionality?

You can use seetest by Experitest to do it.

I could gather from this thread that there is no legal way to automate iOS Apps using Appium from Windows Machine. What kind of iOS Apps does it refer to? Does this refer only to native/hybrid apps or to all kinds of Apps?
Can I launch Mobile Safari Browser and automate a Mobile Web App on iPhone connected to a Windows Box with Appium installed in it??
I received the following Error in Appium Console for not being able to locate Xcode when I tried:
[XCUITest] Error: Could not find path to Xcode

Appium Studio has a Community edition which supports the execution and development of test cases on real iOS devices connected to Windows PCs

The tool is free to use and supports native Appium drivers of all platforms

Disclosure : I work for Experitest as a PM

1 Like

Thank you @tombensim. Can you please tell me if it’s possible to use my already developed test scripts in ruby with this community version of Appium Studio ? Can you please suggest any other ways to edit and reuse test scripts with this Appium Studio ?

I have mac(xcode and simulator) and want to run the scripts from Windows machine.

I connected Appium on MAC with 4723 and provided ip address of mac in Windows where my script execution is triggering.
but unable to connect to Appium. I tried running appium command line and desktop as well
Error–>HTTPConnectionPool(host=‘’, port=4723): Max retries exceeded with url: /wd/hub/session (Caused by NewConnectionError(’<urllib3.connection.HTTPConnection object at 0x000001BBACF24C18>: Failed to establish a new connection: [WinError 10060] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond’))