Issue with Google Map Address Selector

I’m using Google Map to find the address. When i enter the text in the Address Field, it is auto-populating the values in a list as per the attached image above. But there is no resource-id or any element-id present for the highlighted element. Due to this, I can’t able to select the value from the list during automation. Even in the UIautomatorviewer, that highlighted part is not getting selected and thus there is no clue on that part.

Do you anyone know how to resolve this issue and select the value from the auto-list during automation?

Thanks in advance!

no way. just get location of element you enter text. move Y below. and tap by x,y.

Ok is there any tutorial on this?

Also, I have tried like this but not getting the required output:

TouchAction ta1=new TouchAction(driver)
.tap(PointOption.point(234, 195)).perform();

Please let me know what changes I need to do in order to get the list item to be selected.

Enable in phone developer options view touches and check where actually tap happen.

@Aleksei - I have tried your suggestions, but the tap is not happening in the screen. Kindly suggest an alternate in this issue.

I do not see that your action ends with


No visible tap = something wrong in code.

Many examples:

@Aleksei - I have tried something like this and got the required output:

TouchAction action = new TouchAction(driver);, 195)).waitAction(WaitOptions.waitOptions(Duration.ofMillis(2000))).tap(PointOption.point(234, 195)).release().perform();

Thanks for your support…!!