IWD - cannot configure it properly

Hi guys ,

I’ve been straggling with the issue all day long , with no success so far.

Today I’ve reinstalled my xcode to ver 7.3.1 and my previous configuration of iwd has gone…

I’m using appium ver 1.5.3 and as said , xcode 7.3.1

I’ve gone all the posts and threads I’ve seen here / github / stackoverflow and flowed all the steps but still it takes ages to test to run (especially if I use page objects)

It wasn’t the situation before I’ve upgraded the xcode (previously I’ve used 7.1.1)

The steps I’ve preformed are taken from here :
[Instruments without delay questions - appium tests slow](http://iwd removal)

and my final result is :
    Dict {
        Program = /Developer/Library/PrivateFrameworks/DVTInstrumentsFoundation.framework/DTServiceHub
        EnvironmentVariables = Dict {
            LIB_PATH = string /Users/ie54553/node_modules/appium-instruments/thirdparty/iwd7/
            DYLD_INSERT_LIBRARIES = string /Users/ie54553/node_modules/appium-instruments/thirdparty/iwd7/DTMobileISShim.dylib
        JetsamProperties = Dict {
            JetsamMemoryLimit = 0
        POSIXSpawnType = Adaptive
        MachServices = Dict {
            com.apple.instruments.deviceservice.xpc = true
            com.apple.instruments.deviceservice.lockdown = true
        EnableTransactions = true
        Label = com.apple.instruments.deviceservice

but as I said , it doesn’t really work faster …

Any ideas PLS !


tried appium 1.5.3 and xcode 7.3.1, ios 9.2, does not work either…

IWD is pretty critical piece for the performance, without it, two time slow.
appium dev, please help on this, or tell us if it is supported or not for a new release :frowning:

Eventually I did managed to execute / config the iwd script

just remove everything and start from scratch , it worked for me …

The fact your entries start with string is probably the key to your problem. No idea where that’s coming from. :slight_smile:

I know that the IWD script had an issue at one point where it couldn’t UPDATE an existing file but only create the entries from scratch. But I thought that had been corrected sometime last year after I logged a Git issue.

@Christopher_Graham thanks for your reply , probably it was bad copy paste :slight_smile:

It has been fixed since then.


there’s a pull request by @Russ for this issue: https://github.com/appium/appium-instruments/pull/77