Java commands is not executing in appium server

I have installed Appium software in my windows 8.1 PC, When I try to Execute my 1st java program in Eclipse, My Java program is not getting executed in appium application. It was also not displaying any error messages when I run scripts. When I run the program, there is also no error messages in the console and nothing is happening in appium application as well.

I am using windows 8.1 and latest version of Eclipse and appium tools. I have set ANDROID_HOME, JAVA_HOME, and PATH values in Environmental variable, But still i am not getting any Response.

package calTesting;


import org.junit.AfterClass;
import org.junit.Assert;
import org.junit.BeforeClass;
import org.junit.Test;
import org.openqa.selenium.By;
import org.openqa.selenium.WebDriver;
import org.openqa.selenium.remote.DesiredCapabilities;
import org.openqa.selenium.remote.RemoteWebDriver;

import io.appium.java_client.AppiumDriver;

public class Calculator {
AndroidDriver driver;

public void setUp() throws MalformedURLException {
DesiredCapabilities capabilities= new DesiredCapabilities();

capabilities.setCapability("appPackage", "");
capabilities.setCapability("appActivity", "");
driver= new AndroidDriver(new URL(""), capabilities);

public void testCal() throws Exception{
Assert.assertEquals(driver.findElement(By.className(“android.widget.EditText”)).getText(), “6”);

public void tearDown(){

This is what I am getting in my Eclipse Console:

[TestNG] Running:

Default test
Tests run: 0, Failures: 0, Skips: 0
Default suite

Total tests run: 0, Failures: 0, Skips: 0

[TestNG] Time taken by [FailedReporter passed=0 failed=0 skipped=0]: 3 ms
[TestNG] Time taken by org.testng.reporters.EmailableReporter2@13af739: 21 ms
[TestNG] Time taken by org.testng.reporters.JUnitReportReporter@a3ec6b: 1 ms
[TestNG] Time taken by org.testng.reporters.jq.Main@4062d: 71 ms
[TestNG] Time taken by org.testng.reporters.XMLReporter@1a50a4c: 19 ms
[TestNG] Time taken by org.testng.reporters.SuiteHTMLReporter@1d415d9: 23 ms

Can somebody help me how to solve this problem, and Why I am getting this?

You are using annotations of junit and running ur code using testing… import all annotations test,beforeclass,afterclass of testng then it will work . Also make sure your device with name Motorola must be connected to system with app pre installed .

Hi amit,
Thank you for your replay, now I came to know why It is always not responding anything on appium server, It is working fine now.

Thank you…

hi this is sekhar

 how can we try to run Appium script without eclipse?

You can do coding using eclipse and run testng.xml using command prompt