Mac : Issue with Appium-Instruments trace file

I am trying to get battery usage/memory/CPU usage related trace file using appium-intruments.

Below is the command that gets executed while starting the Appium server and after completion of the execution trace file gets created but i am unable to open the trace file through Xcode instruments.

Custom trace template was created using Automation,CUP usage and Energy templates, could you please help me in debugging this issue tried digging through blogs to find answers but unable to find any.

Xcode Version 7.3.1 / Appium Version 1.4.13 (Draco) / iOS 8.3 / MacOS 10.12.2

/Applications/ -t “/Users/UserName/Library/Application Support/Instruments/Templates/Test.tracetemplate” -D /Users/UserName/Desktop/Test/instruments.trace/instrumentscli1.trace -w 5aa308c9xxxxxx322d72b02d72b049159cxxxxxx com.Iphone.MMT -e UIASCRIPT “/Users/UserName/Library/Application Support/appium/bootstrap/bootstrap-228b209b5e94d888.js” -e UIARESULTSPATH /tmp/appium-instruments

@jlipps @penguinho : Saw your comments on one of the threads which helped to reach to this point, could you please help me with this.

Its working now, i had two different versions of Xcode on my machine deleting one of the version worked for me.