Most of the time we are facing the ideviceinstaller issue, how can we resolve?

Most of the time we are facing the ideviceinstaller issue, how can we resolve it?

I faced the issue while automating the iOS application and running in the real devices.

Have anyone got the exact solution to this?

install idevice as
brew install --HEAD ideviceinstaller

It’s impossible because there are too many variables. As suggested, you can install ideviceinstaller if it’s not there, however there are many who have ideviceinstaller installed but still can’t find it on the path. Most of the time it’s because of the IDE that they use, but most don’t bother to list those kinds of details in the description of their problem, and these details need to be teased out.

So tell me about your environment & I may have an answer for you.

I have two Mac machines following are the details:

Mac version = 10.11 (15A284)
xcode version = Version 6.4 (6E35b)
Appium = Version 1.4.13 (Draco)

Mac version =os x Yosemite 10.10
xcode version =Version 6.4 (6E35b)
Appium = Version 1.4.13 (Draco)

I initially though i have solved this issue somehow. It seems that because i have changed the build process it was solved. I am now using maven as build tool and rather than running the tests from i allways use command line. I think thats what fixed the issue for me.

Finally, fixed the issue by setting the User Path as Environment Variable in Run Configuration.

In MAC, open terminal and type: echo $PATH

then we will get list of directory path and copy that path then add it into Run Configuration (as Environment).


1 Like