New Session in Appium Desktop


#1

I am trying to start a new session using Appium Desktop.

I am getting this error when starting the session.

Does anyone know what I am doing wrong?

Thanks!


#2

Can you see your java version if you type java -version on the command line?


#3

Hi, I have managed to fix this and java -version now returns my version java.

I have a different problem now when trying to start a new session.

These are my desired capabilities: image


#4

Can you try adding the appPackage and appActivity capabilities as well and see if you get the same error?
Use this link if you’re not sure on how to get your app package and app activity. Use either the command line method or the APK Info app method.


#5

I have added the appPackage and appActivity to my capabilities and got this error:

The new capabilities I’m using are:
image


#6

Set ‘language’ capability to:

"language": "en",

… and ‘country’ is not supported as capability, but ‘locale’ - e.g.:

"locale": "US" 
"locale": "en_US" 

Please refer to this page to see if your capabilities are correct:
http://appium.io/docs/en/writing-running-appium/caps/


#7

Thanks for the information.

I have set my capabilities to:
image

But I am now getting:


#8

I tried myself and got the same error. You have to do:

"language":"en",
"locale":"US",

#9

Thanks very much! I managed to start a new session.

Now to figure out why I can’t use ‘npm I appium’