No route found. Setting content type to 'text/plain'


i’m new to Appium for UI testing and i’m trying to setup a simple test looking at the C# examples on

I downloaded both WinAppDriver and Appium client and tried to run the CalculatorTest with both.
When i start the WinAppDriver server the test runs fine, but if i start the server via Appium i get this error:

  • No route found. Setting content type to ‘text/plain’ *

I start the server with the default settings.

This is the log i see in the Appium window:

[Appium] Welcome to Appium v1.12.1
[Appium] Non-default server args:
[Appium] address:
[Appium] Appium REST http interface listener started on
[HTTP] --> POST /session
[HTTP] {"desiredCapabilities":{"app":"Microsoft.WindowsCalculator_8wekyb3d8bbwe!App","deviceName":"WindowsPC","platformName":"Windows"}}
[HTTP] No route found. Setting content type to 'text/plain'
[HTTP] <-- POST /session 404 9 ms - 50

Does anyone knows what is the difference between the server that WinAppDriver starts and the one the Appium client starts?

@Carmine_Giordano, did you solve this issue?
I do have exactly the same error, trying the Appium calculator python sample

Make sure that the connection to the appium server is set up correctly. In most examples, the server url is incomplete. The info to fix is in the comments of the file you are using, though, namely to append “/wd/hub” to the driver url. You should have something like this:

private const string WindowsApplicationDriverUrl = "";

1 Like

private const string WindowsApplicationDriverUrl = “”; fixed the problem.