Not able to launch Native APP

HI All,

I am trying to automate Native app with real device case. when i execute the below code i dont see any error in console logs . But i could not see , below code is not launching the app properly. attached the log . I have installed app in real device .

Scenario is : appium_tmobiledigits_failed.txt (13.7 KB)

want to just see Native app is launching or not


DesiredCapabilities capabilities = new DesiredCapabilities();

     capabilities.setCapability("deviceName", "Galaxy S6");
     capabilities.setCapability(CapabilityType.BROWSER_NAME, "");
   capabilities.setCapability(CapabilityType.VERSION, "7.0");
    capabilities.setCapability("platformName", "Android");
    capabilities.setCapability("appPackage", "com.tmobile.digits");
    capabilities.setCapability("appActivity", "");
    driver = new AndroidDriver(new URL(""), capabilities);
automationName: 'UiAutomator2'

Can you add this desired capability and try again

HI Venkatesh … Thanks for your Inputs !!

I have tried with suggested capability . But still i cannot launch the apps.

i am new to Appium. For debugging i have tried to check by launching few apps in android .

i can see calculator, Mobile pass and whatsapp app is launching successfully as expected.

Even for facebook app is not launching properly . I am copy pasting the app package , activity below for Digits . whenever see some differnece there . it is not working

Digits app :

appPackage : com.tmobile.digits
app activity :

facebook app
app package : com.facebook.katana
app activity : com.facebook.katana.dbl.activity.FacebookLoginActivity

do u think is package & activity name makes any difference ? or UI view back any difference ? . Kindly advice…

I think the developers have an option to disable automation on their production version. That’s the reason you are not able to launch them.

Can you upload full appium server log; current file you’ve uploaded doesn’t have complete log.

HI Vikaram,

Please refer the attached latest log .

Thanks,Latest_log_appium.txt (16.6 KB)

You’ve missed to specify “app” capability.

Do we really need to give app path when we are using appPackage and appActivity is already given in desired capabilities?

@vnvbsudhakar As per documentation it’s not needed but I need to try it myself to confirm this new info for me.

I looked at appium server log and it seems session is created successfully. I’m not sure why app is not displayed on the device though. To keep it simple try to launch with Appium Desktop and see what’s happening

HI Vikaram , I have tried with Appium desktop. But still i app is not displayed . Please refer the attached logs and screen shot .

Mythiliappium_desktoplogs.txt (18.5 KB)

Hi Mythili,

You should not provide the CapabilityType.BROWSER_NAME, appPackage and appActivity at the same time.
Try using (BROWSER_NAME) OR (appPackage and appActivity) one at a time. You can avoid using app capability if you have the app already installed on your device.