Old tests which are automated using xcode 7.3 and appium 1.4.13 are failing with new xcode 8 and appium 1.6.0 beta2

When I try to run old tests which are automated using xcode 7 .3and appium 1.4.13 on appium 1.6.0 beta2 and xcode 8 ,some tests are failing .

It is failing mostly because it is unable to identify the elments using xpath on all iphones with 9.3 and 10.0.

Can any one please suggest me why xpaths are not working with latest xode 8 and appium and what is the alternative for this.

Do I need to change my old scripts entirely ?

Thanks in advance.

Have you changed to xcuitest framework ?

from what I saw , appium 1.6 still doesn’t support gestures (getting an exception for all my swipe code…)

I added the below desired capability to my old framework.
capabilities.setCapability(“automationName”, “XCUITest”);

I tried swipe up gesture and it is working for me .

strange , I got not implemented error …

Instead of using gesture methods…I used my own logic to do swiping.May be that is the reason it is working.

I’m using directly TouchAction class … (any way , this is what actually been done by driver.swipe)

Is ur elements are identified using xpath.
Are you able to launch appium inspector.