Original error: UiAutomator quit before it successfully launched

I’m getting the following error when trying to open application (Netflix) from a robotframework project (with AppiumLibrary installed):
Original error: UiAutomator quit before it successfully launched

the weird thing that when trying to connect via Appium Inspector Window with the same apk (for android 5.0 in my case) it succeeds!

I tried to test it on other device with android 4.4 (with the relevant apk) but got the same.
I tried to test it with google translate apk, and I got the same error!

What can be the root cause?
Robot version? Android version? A problem with the apk itself?


I faced this issue a few times.
What i did to solve it was restarting adb server and appium server
After the restart, the issue resolved

Thank for your reply Shay.
I tried restarting as well but no luck :confounded:

I tried with different Android devices with diferent android versions and still got the same.
I can see in the log:

shell “ps ‘uiautomator’”

info: [debug] No matching processes found

I tried the samecommand from adb shell, and actually no such process there.

It’s not clear to me why when running appium from robot its trying to locate the uiautomator process.
When running Appium from Inspector it doesn’t and the application launch!

I found that there was fix for that issue (#1517), PSB:

But I didnt manage with merging the changes