Package selendroid.xx.xx.xx does not have a signature matching the target

This might be a bug, will file on Github if no solution is found within 2 days.
I have a hybrid App (Ionic) and I’m trying to run using the selendroid automationName on Android devices. I keep getting the “package xx.xx.xx.xx does not have a signature matching the target” error.

I tried uninstalling both the Apk and Selendroid Apk on the emulator and trying again with no luck. My code:

const wdio = require('webdriverio');

const opts = {
  port: 4723,
  desiredCapabilities: {
    platformName: "Android",
    platformVersion: "6.0",
    deviceName: "Android Emulator",
    app: '/path-to-apk/android-debug.apk',
    automationName: "selendroid",
    autoWebview: true

const client = wdio.remote(opts);

  .contexts().then(function (contexts) { 
        return client.context(contexts[1]); 

    // do some web testing

I even added useKeystore: true and got the same error, Appium version 1.7.2.
What could the issue be please, thanks in advance.