Permission issues- (Error: EPERM, rename)with appium installation and execution in a windows machine


It all started when after a long time I just tried parallel execution with selenium grid. I started getting error(same code and configuration was working before, and 1 in 100 attempts its working) something like this

Then I tried a fresh install of appium using npm and I started getting errornpm-debug.log (28.6 KB) npm ERR! tar.unpack untar error the ziptorrent file inside the package. then I checked %App Data%Roaming/npm-cache folder and tried to unzip the package manually and I got the error This is definitely not an permission issue as I checked all my user privilages before installation. And one more question is that within windows appium package why we need macosX file ?

@bootstraponline @jlipps first error(rename apk) occurs when I am trying to execute parallel tests on multiple devices. I digged deeper and found that it is because of zipalign giving same name to apk everytime, is this enhancement for same issue? Please suggest.

Also if possible can you guys look in my second issue, I am not able to install appium using npm, it is not very critical though.