Problem with Signing & Capabilities on real device

Hi All,

I am having problem with setting up an WDA on a real device, I already have the same setup working on another computer that I am trying to copy the settings from. But I must be missing some crucial part, and is hoping that bright individual can point me in the right direction what might be the problem.

I have copied the same signing settings from my other computer (atleast what I can see).

I can build the project (IntegrationApp) from Xcode to the real device, but when I try to start the WDA agent by using this command from the WDA folder:

xcodebuild build-for-testing test-without-building -project WebDriverAgent.xcodeproj -scheme WebDriverAgentRunner -destination ‘id=’

Error in terminal:
/Users/MacComputer/.appium/node_modules/appium-xcuitest-driver/node_modules/appium-webdriveragent/WebDriverAgent.xcodeproj: error: Signing for “WebDriverAgentRunner” requires a development team. Select a development team in the Signing & Capabilities editor. (in target ‘WebDriverAgentRunner’ from project ‘WebDriverAgent’)

2024-01-31 17:00:35.843 xcodebuild[1810:20711] Writing error result bundle to /var/folders/n7/nz4jln4d4vsg2k5nbkgl2zw40000gn/T/ResultBundle_2024-31-01_17-00-0035.xcresult

xcodebuild: error: Failed writing xctestrun file: The folder “WebDriverAgentRunner_iphoneos17.2-arm64.xctestrun” doesn’t exist…

MacComputer@MacStudtestning appium-webdriveragent %

File ResultBundle_2024-31-01_17-00-0035.xcresult:
Failed writing xctestrun file: The folder “WebDriverAgentRunner_iphoneos17.2-arm64.xctestrun” doesn’t exist.

Hope that someone can point me in the right direction, have been scratching my head a while now. Since I have the same setup on another computer (what I can see in Xcode atleast).

Kind regards

I always build IntegrationApp, WebDriverAgent.lib, and WebDriverAgentRunner. Each of these target apps has it’s own build settings, so make sure you change them appropriately.

As always, make sure you have read the following thoroughly. It’s a great reference:

Edited to add: You don’t mention Appium version, so just to make sure–>Use Appium 2 with iOS 17 or it will never work…

Thanks for the answer @wreed I really appreciate that you took your time and had a look at my problem. However I look at the documentation that I have scrutinize a number of times before your advice and even after looking at it again I continue to get the same problem. In addition I am running Appium 2.4.1 on the computer and I have iOS 17.2 installed on the real device.

Did you add your developer certificate on machine where you running this command?

Yes that I had @Aleksei, I think I have solved the problem know by removing the folder of appium-webdriveragent and re-install the npm appium-webdriveragent package. Then by configuring the Integrationapp, WebDriverAgentLib and the WebDriverAgentRunner in that order with a uniqe Bundle Identifiers e.g:

  1. com.<uniqe_name>.IntegrationApp
  2. com.<uniqe_name>.wda.runner
  3. com.<uniqe_name>.WebDriverAgentLib

Feelt like the certificates had “burnt” and was “stuck” until I did the re-installation. That is how I at least experienced my problem to be solved.