Problem with upgrading selenium 2.53.1 to 3.3.1 with appium 1.6.3

I got this error. FAILED CONFIGURATION: @BeforeTest setup
org.openqa.selenium.SessionNotCreatedException: Unable to create new remote session. desired capabilities = Capabilities [{appActivity=com.proxfinity.activities.common.SplashActivity, appPackage=com.proxfinity, appiumVersion=1.6.3, platformVersion=5.0.1, platformName=Android, deviceName=Spirit}], required capabilities = Capabilities [{}]
Build info: version: ‘3.3.1’, revision: ‘5234b325d5’, time: ‘2017-03-10 09:10:29 +0000’
System info: host: ‘Mukunds-MacBook-Pro.local’, ip: ‘fe80:0:0:0:1469:7555:31ab:988e%en0’, ‘Mac OS X’, os.arch: ‘x86_64’, os.version: ‘10.12.1’, java.version: ‘1.8.0_112’
Driver info: driver.version: AndroidDriver
at org.openqa.selenium.remote.ProtocolHandshake.createSession(
at org.openqa.selenium.remote.HttpCommandExecutor.execute(
at io.appium.java_client.remote.AppiumCommandExecutor.execute(
at org.openqa.selenium.remote.RemoteWebDriver.execute(
at io.appium.java_client.DefaultGenericMobileDriver.execute(
at io.appium.java_client.AppiumDriver.execute(
at org.openqa.selenium.remote.RemoteWebDriver.startSession(
at org.openqa.selenium.remote.RemoteWebDriver.(
at org.openqa.selenium.remote.RemoteWebDriver.(
at io.appium.java_client.DefaultGenericMobileDriver.(
at io.appium.java_client.AppiumDriver.(
at io.appium.java_client.AppiumDriver.(
at LoginTest.LoginTest.setup(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at org.testng.internal.MethodInvocationHelper.invokeMethod(
at org.testng.internal.Invoker.invokeConfigurationMethod(
at org.testng.internal.Invoker.invokeConfigurations(
at org.testng.internal.Invoker.invokeConfigurations(
at org.testng.TestRunner.beforeRun(
at org.testng.SuiteRunner.runTest(
at org.testng.SuiteRunner.runSequentially(
at org.testng.SuiteRunner.privateRun(
at org.testng.SuiteRunnerWorker.runSuite(
at org.testng.TestNG.runSuitesSequentially(
at org.testng.TestNG.runSuitesLocally(
at org.testng.remote.RemoteTestNG.initAndRun(
at org.testng.remote.RemoteTestNG.main(
Kindly help

Please provide more details. Presumably, you were using 2.53.1 with a version of appium < 1.5. When you installed 1.6.3, did you configure it?

is there any setting need to be done? as i have just installed it and used it.

How exactly are you “upgrading” selenium for your java project? I’m using gradle and all I include in my build.gradle file is the latest Appium java-client 5.0.0-BETA6. Then that seems to pull in the appropriate version of Selenium libraries for me.

I use maven and i included selenium 3.3.1 in the pom dependency

Thank you it worked once i updated it to java-client 5.0.0-BETA6

it worked twice now again i am getting this error message after updating to javaclient 5.0.0 beta6"A new session could not be created. Details: Problem getting session data for driver type AndroidDriver; does it implement ‘get driverData’? (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 0 milliseconds"