Problems with running appium in --no-reset SOLVED

Hey there,
I seem to have stumbled on the problem of not being able to run scenarios/tests back to back and stay signed in after my test.
I’m double checking to make sure my settings are correct.
Here’s what I have (I script this out so variables are passed in):

  1. Starting appium like so: appium -a localhost -p $android_appium_port -bp $android_appium_bootstrap_port --no-reset
  2. Desired Capabilities:
platformName = "Android"
platformVersion = "4.4"
deviceName = "Galaxy S4"
appPackage = "com.x.y.z"
appActivity = "com.x.y.z.activity"
appWaitActivity = "com.x.y.z.activity1,com.x.y.z.activity2"
noReset = true
fullReset = false
app = "myapk.apk"

port = 4900
  1. I’m not doing any resets in any after hooks that I am aware of.
    Genymotion: Android 5.0 and 4.4 various VMs.
    Appium 1.4.16

  2. Here is my appium logs full gist of the test run:
    Any help is most welcome.
    Thanks in advance!

PS. Just in case this is a bug -

I had some cruft in the activity names. once that resolved, things worked out for me.