Ruby: Appium driver doesn't show available API or other commands


I am new to Appium and currently trying to develop an automation framework using Appium + Cucumber in Ruby language (which is also new to me). I am using Rubymine as my IDE for this and I am facing a basic issue.

After coding the env.rb part, I am not seeing the API command or any other supported Appium commands when I try to use the $driver global variable for any further operation inside my individual pages. I expect the IDE (Rubymine) to show all these available commands specific to the Appium driver when I write “$driver.” . I expect it to show options like $driver.find_element etc.

I have worked on similar stuff in Java and it completes the code all the item and I was able to look up any Java Doc available. I think this is one of primary reasons for using an IDE.

Is this the way it is or am I doing something wrong? Any suggestions will be really helpful.

RubyMine can’t autocomplete Ruby code. If you’re looking for auto complete, Java is better.

Now thats really sad to hear. So in case of a simple syntax mistake, I can find it out only when I run the code? I just tried to misspell the $driver and RubyMine didn’t throw any error.

Right, RubyMine has no idea if there’s a syntax error. Java is miles ahead in terms of IDE support when compared to Ruby. RubyMine can do some basic checking however most of the time it doesn’t do anything.