Run Appium 1.5 from source?

In previous versions of Appium we were able to download the source code, compile and run. But with Appium 1.5 seems like is not the case, or at least not the same way Appium 1.4.16 was doing it.

Since I am not able to install in a corporate machine with npm because restrictions, how can I run the new version from source?

You don’t give a lot of info on how you are trying to do this, or what you’ve tried.

Have you tried this:

git clone

Yes I have tried. Actually cloning is not the problem, the problem is to run Appium after cloning. Previous versions you needed to run to compile Appium. Then you could run Appium from the bin folder.

Since now we don’t have a and there is no Appium in the bin folder, how do we run it if we decide to clone the repository?

That is a much better explanation of the problem. Have you read this thread:

Check out post #35:


What a great help!
Thank you very much :smile:

Now, do you know if the server flags changed?

I’m not aware of any. Are there any particular one’s you are having problems with?

I am seeing this error updating to 1.5 source :slight_smile:
➜ node_modules git:(93004e1) pwd
➜ node_modules git:(93004e1) sudo authorize-ios
info AuthorizeIOS Enabling DevToolsSecurity
info AuthorizeIOS Updating security db for developer access
info AuthorizeIOS Granting access to built-in simulator apps
info AuthorizeIOS The xcode directory is : /Applications/
info AuthorizeIOS Changing ownership to ‘sri’ on directories: /Applications/, /Applications/, /Library/Developer/CoreSimulator/Profiles/Runtimes/iOS 7.1.simruntime/Contents/Resources/RuntimeRoot/Applications, /Library/Developer/CoreSimulator/Profiles/Runtimes/iOS 8.1.simruntime/Contents/Resources/RuntimeRoot/Applications
ERR! AuthorizeIOS Encountered an issue changing user priveledges for iOS sim app dirs: /Applications/,/Applications/,/Library/Developer/CoreSimulator/Profiles/Runtimes/iOS 7.1.simruntime/Contents/Resources/RuntimeRoot/Applications,/Library/Developer/CoreSimulator/Profiles/Runtimes/iOS 8.1.simruntime/Contents/Resources/RuntimeRoot/Applications
ERR! AuthorizeIOS Error was: Command ‘chown -R sri: /Applications/ /Applications/ ‘/Library/Developer/CoreSimulator/Profiles/Runtimes/iOS 7.1.simruntime/Contents/Resources/RuntimeRoot/Applications’ ‘/Library/Developer/CoreSimulator/Profiles/Runtimes/iOS 8.1.simruntime/Contents/Resources/RuntimeRoot/Applications’’ exited with code 1