Run sh ./Scripts/bootstrap.sh -d doesn't work for me :/

hello
when I run the script bootstrap.sh I get this :

Mac-mini-de-admin:WebDriverAgent admin$ sh ./Scripts/bootstrap.sh -d
-e Fetching dependencies
Error: Command "bootstrap" does not exist.

do you know what have i missed ?

and when i run simply the tests i get in the appium logs :

 [XCUITest] Error: Command '/bin/bash Scripts/bootstrap.sh -d' exited with code 1
    at ChildProcess.<anonymous> (../../lib/teen_process.js:66:19)
    at emitTwo (events.js:100:13)
    at ChildProcess.emit (events.js:185:7)
    at maybeClose (internal/child_process.js:850:16)
    at Socket.<anonymous> (internal/child_process.js:323:11)
    at emitOne (events.js:90:13)
    at Socket.emit (events.js:182:7)
    at Pipe._onclose (net.js:477:12)
 { [Error: Command '/bin/bash Scripts/bootstrap.sh -d' exited with code 1]
  stdout: '\u001b[1mFetching dependencies\n',
  stderr: 'Error: Command "bootstrap" does not exist.\n',
  code: 1 }

it seem that the command carthage bootstrap $USE_SSH is throwing the error … maybe i should update carthage ?

HEY
I solved my problem (it was really stupid) i just reinstalled carthage with brew …

brew uninstall carthage
brew install carthage

that’s all now i have the probleme that the app open and crash instantly … i guess it’s a bad installation somthing like this … i had already post my problem here : {1.6}{IOS}{WebDriverAgent} can't finish the installation of webDriverAgent
thx if you have any idea

Hi, I’m facing with the same problem, Original error: Command ‘/bin/bash Scripts/bootstrap.sh -d’ exited with code 1 . I have tried:

brew uninstall carthage
brew install carthage

but it didn’t help to me :-(( Any clues ?

I find a solution, think could be helpful to others: my cathage was installed twice, using npm and bower. Remove both and install one using bower

MacBook-Pro:WebDriverAgent user$ ./Scripts/bootstrap.sh -d
-bash: ./Scripts/bootstrap.sh: No such file or directory
MacBook-Pro:WebDriverAgent user$

help me please

how to clean plz I m new babies.

I got the same problem that when trying to do, " bash ./Scripts/bootstrap.sh " , the response for that command is like, no such file or directory found.

i had done many things, like reinstalled carthage too.

help me in solving this problem please.