send_keys won't sent text

Hello,
I’m just starting up with appium and got to launch my app, but I text is not being sent to app

el = self.driver.find_elements_by_class_name(“android.widget.EditText”)
el[0].send_keys(“98765”)

But when I see script running it looks like a doble tap( the Copy option Appears) and text is not being sent

Is there anything to consider when trying to use send_keys? I’m using implemention for python on appium.
Thanks

try first tap(click) on element as workaround.
also mention your Appium Server version.

Tried that, still no text send, keyboard is displayed but no text.
I’m using 1.4.13 version

maybe make sense try with 1.4.12. i see many issues there in github. we still use 1.4.12.

I downgraded it, and still have same issue

well :-). we use Java-client and have no problems (at least similar).
final work around.

  • click on field
  • use “press_keycode” with each char needed to enter.

also it is sometimes valid that actually it is needed to enter value into another textbox. suggest to check by try to enter text into “el[0]” then el[1] untill last.

With send_keys, I sometimes have problems entering text similar to the text fields you’ve illustrated. In these cases, I’ve fallen back to using my own methods referencing execute_script.

Furthermore, You can within your test change the sendKeysStrategy inline to help with this.
Take a look at this github post. I’m hoping it points you straight.
Cheers!
Eric