Slow Appium tests on OS X 10.12 Sierra [SOLVED]

Does anybody have problems with running Android tests with Appium 1.5.3 after updating from OS X 10.11 to 10.12?
Server starts correctly, Android Driver starts correctly too, but not every element will be found in app, tests run very slow, very often happens “Failed to locate element. Clearing Accessibility cache and retrying.”
Please, help me to fix this((

1 Like

How about appium 1.6beta

Does it can help? Ok, I’ll try

No, it didn’t help(
I’ve noticed that freezes happen after checking for some element is not present or visible. Every time after that test will be frizzed for about 1 minute. I don’t have any implicit waits in my test, but even if I set implicit wait to 2 seconds - it won’t help(

I’ve found a solution - disabling SIP and reassigning localhost.

Could you please explain how you do that and your step?


  1. Disable SIP like described here:
  2. Edit hosts file like described here:

Good job. Thanks Dezik.

Hey Guys …did you also receive an error on Mac OS Sierra ? I am not able to have appium running on 10.12
Here is the appium doctor message.
Error: Could not detect Mac OS X Version from sw_vers output: '10.12

I have the same error.
But appium server works fine

Even i was facing similar issue.
Try running these commands :
npm uninstall -g appium-doctor
npm install -g appium-doctor