SplashActivity_' never started

Hello, I have a question and I will be happy if anyone can help.

When I try to Start Session I got the following error
An unknown server-side error occurred while processing the command. Original error: Cannot start the ‘com.xxx.at.xxx’ application. Visit https://github.com/appium/appium/blob/master/docs/en/writing-running-appium/android/activity-startup.md for troubleshooting. Original error: ‘com.xxx.xxx.SplashActivity_’ or ‘com.xxx.at.xxx.com.xxx.kaufland.SplashActivity_’ never started. Visit https://github.com/appium/appium/blob/master/docs/en/writing-running-appium/android/activity-startup.md for troubleshooting

Im using Mac
Appium Version 1.15.1 (1.15.1.20191013.2)
Android v 3.6.3
java 14

did you follow link and this not solve your problem? what you tried?

Thanks Aleksei!
I tried, but I met an issue when execute adb shell am start -W -n com.myfixedpackage/.myfixedactivity.MainActivity -S -a android.intent.action.MAIN -c android.intent.category.LAUNCHER -f 0x10200000 .

java.lang.IllegalArgumentException: Bad component name: com.xx.xx.MainActivity
at android.content.Intent.parseCommandArgs(Intent.java:7251)
at com.android.server.am.ActivityManagerShellCommand.makeIntent(ActivityManagerShellCommand.java:317)
at com.android.server.am.ActivityManagerShellCommand.runStartActivity(ActivityManagerShellCommand.java:409)
at com.android.server.am.ActivityManagerShellCommand.onCommand(ActivityManagerShellCommand.java:172)
at android.os.ShellCommand.exec(ShellCommand.java:104)
at com.android.server.am.ActivityManagerService.onShellCommand(ActivityManagerService.java:9774)
at android.os.Binder.shellCommand(Binder.java:881)
at android.os.Binder.onTransact(Binder.java:765)
at android.app.IActivityManager$Stub.onTransact(IActivityManager.java:4498)
at com.android.server.am.ActivityManagerService.onTransact(ActivityManagerService.java:2741)
at android.os.Binder.execTransactInternal(Binder.java:1021)
at android.os.Binder.execTransact(Binder.java:994)

I tried different paths. I took the main and first activity from the dev. , but the Activity is not starting. I am able to open the app directly with emulator, but when I try with Appium its not working

this does not look right!

that’s the example from https://github.com/appium/appium/blob/master/docs/en/writing-running-appium/android/activity-startup.md , I tried many different paths but same story. Do you know how can find the right path ?

@enedelina write your code. how you create capabilities.

I fixed it as I added “appWaitActivity”: “*” to capabilities. Thanks a lot for your help!

Yes. Wanted suggest same to forget about any names.

1 Like